Post Reply 
 
Thread Rating:
  • 336 Votes - 2.68 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linking via a drop down list...
08-19-2011, 03:31 AM
Post: #1
Linking via a drop down list...
Hello and good day,

I am new to the whole MODx scheme of things, CMS in general. With that being said, I have just graduated from a Web Development program that did not really cover CMS'es at all (just the creation of our own in PHP).

Besides all that, I have a webpage now that was originally going to incorporate some AJAX page loads... but then the client I am working for wanted to be able to edit the content easily. I thought I would try MODx as it was recommended so highly elsewhere.

My page has a landing page, six template quasi landing pages as well as a navigation bar that has 60 some odd page loads that I would like to have loaded to the respective pages.

The problem I am having is getting all my links to show and the certain page to load. Right now (using Wayfinder) it only picks up my six other heading page loads but not the links inside of them. I know that for each page in the "Resource" section it needs to have those links and it does.

Now I am not sure that this is the right way but I have also gone ahead and created 90 chunks so that the data can be loaded for each page requested.

Any help or direction would greatly be appreciated.


WDH


Find all posts by this user
Quote this message in a reply
08-19-2011, 04:32 AM
Post: #2
RE: Linking via a drop down list...
Welcome to the forums. I'm having a little trouble understanding your set up, what you're trying to accomplish with Wayfinder, and how the pages relate to each other. Does the template you're using facilitate dropdown lists in the first place? This needs to be in place in your HTML before your incorporate it into MODx.


Find all posts by this user
Quote this message in a reply
08-22-2011, 04:21 AM
Post: #3
RE: Linking via a drop down list...
WebDevHead
Wow, that sounds complex!! From working with a simple template from the coding pad tutorial examples it sounds like maybe youre not specifying the depth parameter?


Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content