Post Reply 
 
Thread Rating:
  • 299 Votes - 2.58 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Friendly URLs
12-13-2011, 04:30 AM
Post: #1
Friendly URLs
Hello

Sorry if this is wrong area. I use Modx for my site but can't work out how to get friendly URL's - can anyone help me please?

I am using MODx Revolution 2.0.6-pl (advanced) for my CMS.

I have tried and failed to find a solution for over a year; surely there must be a way to do it?


Find all posts by this user
Quote this message in a reply
12-17-2011, 08:26 AM
Post: #2
RE: Friendly URLs
There's definitely a way to do it. What part are you getting stuck on? Do you know where to find the system settings to turn FURLs on?

(12-13-2011 04:30 AM)draelectricals Wrote:  Hello

Sorry if this is wrong area. I use Modx for my site but can't work out how to get friendly URL's - can anyone help me please?

I am using MODx Revolution 2.0.6-pl (advanced) for my CMS.

I have tried and failed to find a solution for over a year; surely there must be a way to do it?



Find all posts by this user
Quote this message in a reply
12-20-2011, 09:35 PM
Post: #3
RE: Friendly URLs
I can't get the website to display friendly url's in the url bar. For example, my 1st landing page which I have set at http://www.draelectricals.co.uk/site/pat-testing shows in the url as http://www.draelectricals.co.uk/site/index.php?id=25

I don't know what you mean by FURLs - it's my own website, I'm not a developer


Find all posts by this user
Quote this message in a reply
12-24-2011, 02:40 AM
Post: #4
RE: Friendly URLs
FURLs is Friendly URLs.

To make friendly urls work in MODX revolution, you first need to make sure that modrewrite is turned on on your server. In most cases it is but you can email your hosting company to make sure.

Second you need a properly configured .htaccess file. MODX comes with a file names ht.access that in most cases you just need to rename to .htaccess. If your site is sitting in the root then that may be all you need to do. However, if your site is in a folder or subdomain you may need to edit one line to make it work.

Finally you have to turn on and edit the friendly urls settings in the manager, under System Settings->friendly urls.

You also need to make sure you have this line somewhere between the
Code:
<head> </head>
tags in your template:

Code:
<base href="[[!++site_url]]" />

You can find some more instructions with screenshots at http://rtfm.modx.com/display/revolution2...endly+URLs

Hope this helps


(12-20-2011 09:35 PM)draelectricals Wrote:  I can't get the website to display friendly url's in the url bar. For example, my 1st landing page which I have set at http://www.draelectricals.co.uk/site/pat-testing shows in the url as http://www.draelectricals.co.uk/site/index.php?id=25

I don't know what you mean by FURLs - it's my own website, I'm not a developer



Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content